The Pantheon

Seven Heavens => Asgard - Technical Help => Topic started by: NineInch on December 09, 2007, 09:51:45 PM



Title: ROMs not working...
Post by: NineInch on December 09, 2007, 09:51:45 PM
Alright, so I asked for some help with this a while ago, but I couldn't figure out how to fix the problem.
This shows up on several ROMs after I've patched them:
"??@??@??@??@??@??@??@??@? [bad checksum] LoROM, Corrupt, Type: ROM+RAM, ModeL 82, TV: PAL, S-RAM: Corrupt, ROMId: ?@?? Company: 40 CRC32: CEC9B8D1"

I don't think it's just a buggy file, since they all work fine until I patch them.
Any ideas?

(And I use a Mac, if that has anything at all to do with it)


Title: Re: ROMs not working...
Post by: Wight on December 09, 2007, 10:07:59 PM
First guess would be header issues.  If it is, then shame on you for not reading the ReadMe.  It's begging you to be read . . . Why won't you have mercy on the poor thing?

If it's not a header issue, then I dunno.


Title: Re: ROMs not working...
Post by: NineInch on December 09, 2007, 10:13:27 PM
Yeah, I've looked through the read-me a few times, but I can't find anything about header removal. All it says is read above, not really how to do it.


Title: Re: ROMs not working...
Post by: Dsvaun on December 09, 2007, 11:06:07 PM
Get a SNEStool and use the remove header option.


Title: Re: ROMs not working...
Post by: JayBee on December 10, 2007, 01:46:16 AM
Dsvaun, he's on a Mac. I don't think SNESTool has a Mac version.
...
Not that I have a clue what an aspiring  Mac owner WOULD use to remove a header.


Title: Re: ROMs not working...
Post by: Gideon Zhi on December 10, 2007, 09:22:06 AM
NSRT.


Title: Re: ROMs not working...
Post by: NineInch on December 10, 2007, 12:04:22 PM
I can't find a site to download it from. And my computer can't download from buttons since I downloaded and removed a crappy download program.

Help?


Title: Re: ROMs not working...
Post by: Gideon Zhi on December 11, 2007, 06:20:45 PM
I can't find a site to download it from. And my computer can't download from buttons since I downloaded and removed a crappy download program.

Help?

I help those who help themselves.


Title: Re: ROMs not working...
Post by: Fynn on December 12, 2007, 09:43:22 AM
Did you know that this quote actually isn't in the Bible? I just looked it up, weird.

NSRT seems to be hard to find since the website appears to be broken. There's a link to the Mac version 3.3 on Zophar's Domain that works, here (http://www.zophar.net/utilities/download/nsrt33m.zip).

Just use -addhead or -remhead to mess with the headers.


Title: Re: ROMs not working...
Post by: NineInch on December 13, 2007, 12:06:08 PM
I can't find a site to download it from. And my computer can't download from buttons since I downloaded and removed a crappy download program.

Help?

I help those who help themselves.

Alright, I'll try.. I'm pretty sure I used that NSRT thing, but it made no sense at all


Title: Re: ROMs not working...
Post by: Wight on December 13, 2007, 06:33:51 PM
Did you know that this quote actually isn't in the Bible? I just looked it up, weird.

Hercules helps those who helps themselves.  That's the original quote from Aesop's Fables.


Title: Re: ROMs not working...
Post by: NineInch on December 14, 2007, 02:10:55 PM
Well, I don't know how to use this thing...
Guess I'm outta luck