jips doesn't work anymore...?

You are here: The Pantheon / Seven Heavens / Asgard - Technical Help / Topic: JIPS doesn't work anymore...?

Gon is calm
 right now.




10972 Posts, 523 Topics, 737 Members, Latest Member: PM_ME_GANBARUBY

This forum is Powered by SMF 1.1.21 | SMF © 2005, Simple Machines integrated by Datschge basing on Simplicity by Bloc
 (Read 3107 times) [1]

  JIPS doesn't work anymore...?
« on: January 06, 2011, 02:27:33 AM » by aztechrome
« Last Edit: January 06, 2011, 02:07:59 PM by aztechrome »
So I'm trying to hard-patch my copy of Ancient Magic with the new IPS patch. Everytime I patch my rom with the .ips file using JIPS, the game becomes unstable and locks up my emulator. Futhermore, the pre-patch "backup" that JIPS creates is also corrupted by the patching process. This meant that I had to go and dig through my Japanese roms again to relocate a clean copy.
HERE's the weird part. If I just give the same name to the .smc and .ips files and allow ZSNES to soft-patch the game on load, everything works PERFECTLY! If I use JIPS to patch that same ROM, it trashes it, and the backup copy?

Does anyone know what is going on? JIPS used to work fine for me... I'm on Linux. Anyone else having this problem?  Would anyone care to look at the .log file JIPS created when it applied the patches? What could possibly go wrong with a Java-based IPS patcher running in the latest JRE?

[edit] I will attempt to use a PERL script I found on a debian forum to do the hard-patch. If that fails, I suppose I will have to bust out with WINE, and try to emulate Windows-based patcher, which is a ridiculous amount of overhead to maintain just to apply a patch. I will post if these other patchers work properly, but I am not optimistic. Please comment if you have any ideas. [/edit]

Below is a dump of nsrt output, and verification of filesize, checksum, and lack of header.

$ ls -l | grep -i amagic.smc
-rw-r--r--  1 ross ross    1572864 2004-05-13 19:19 amagic.smc

$ nsrt -info amagic.smc

---------------------Internal ROM Info----------------------
       File: amagic.smc
       Name: _____! ______            Company: Hot B Co.
     Header: None                        Bank: LoROM
Interleaved: None                        SRAM: 64 Kb
       Type: Normal + Batt                ROM: 12 Mb
    Country: Japan                      Video: NTSC
  ROM Speed: 200ns (SlowROM)         Revision: 1.0
   Checksum: Good 0xEBA0            Game Code:
      CRC32: D5B09EEF
       Name: Ancient Magic - Bazoo! Mahou Sekai
    Country: Japan                   Revision: 1.0
     Port 1: Gamepad                   Port 2: Gamepad
    Genre 1: RPG                      Genre 2: Unknown

... Et tu, Brute? ...
IP Logged

  Re: JIPS doesn't work anymore...?
« Reply #1 on: January 06, 2011, 03:37:36 PM » by aztechrome
« Last Edit: January 06, 2011, 04:57:06 PM by aztechrome »
Update: Success!

I performed the patch with a PERL script. Now everything seems to work fine.
The script is located here: http://www.zophar.net/fileuploads/1/3142ixteo/ips.txt

Still it seems that JIPS just shreds my ROMS these days...
Unfortunately, the only IPS patching option native to Linux appears to be this v0.01 PERL script written back in 2003 by an author who admits that this is a piece of hastily written alpha software without an elegant solution to handling 3-byte numbers during patching.

Anyone have a clue what's wrong with JIPS? I'm not used to simple JAVA applications going completely haywire like this... :P
Anyone know of a Linux-native IPS patcher that's less sketchy than this .01 alpha PERL script?  Again, I'd rather not have to do this through DOSBOX or WINE. Ideas?

[edit] I have now patched clean Japanese copies of Metal Max Returns, Danzarb, FM: Gun Hazard, and Ancient Magic using the PERL script. All seem to work perfectly. The same operation, when performed by JIPS thrashes all of the aforementioned. So it's _gotta_ be JIPS somehow....  [/edit]

... Et tu, Brute? ...
IP Logged

  Re: JIPS doesn't work anymore...?
« Reply #2 on: January 08, 2011, 07:09:34 AM » by alaras
Uninstall and reinstall?  EIther that, or use Wine and switch to Lunar IPS
IP Logged

 (Read 3107 times) [1]
Jump to: